Increase your income with Hive. Invite your friends and earn real cryptocurrency!

AMD 7800XT Support

Hello. I bought a new 7800xt graphic card to add in my existing rig with other 6000 series amd. And it’s not fully supported. Didn’t know that 7000 series amd cards are not supported. I would not buy it if I knew. So I have read some similar topics about 7000 series at this forum. Tried with beta of hiveos and I found out that I can’t even control the PL. I can’t mine with 7800xt now because it has high power consumption at stock. When can be full control of 7000 amd cards be provided? Thanks

We don’t currently have an ETA for full support, just keep an eye out on release notes for future beta/stable images.

im curious, was there a certain algo that made you want to purchase that gpu over others?

I’m using my 6000 series rig of 4 cards with different algos. Just wanted to add the 5-th card and the price was good, did not want to buy used 6000 cards… What does it depend on when the support of this 7000 cards will appear?

the way that OC are handled on the driver level I believe are quite different from navi/navi2 gpus. That plus them not being great value mining cards doesnt help either.

So the reason is - no suitable graphic drivers for 7000s cards for linux now?

the implementation for OC changed at the driver level, its not that it doesnt exist, its just not the same as previous

AMD devs made a lot of changes in driver code for AMD RDNA3 support during 2023.
Now it’s look much better than one year ago :upside_down_face:
But what about Hive?
AMD Radeon RX 7900 XTX / XT is supported on the current Beta Image (linux kernel 6.1.35), but the driver does not fully support overclocking or fan controls.

Awaited next Beta Image will:

  • added support for all RDNA3 series (7600 / 7700 / 7800 / 7900)
  • add fan controls
  • added partial voltage control by core voltage offset so the efficiency of GPUs will be better
1 Like

Ah, I would like it to happen as soon as possible, and I think not only me. It’s not worth mining with my 7800xt now, it works at stock with 240-260 watts in hive , and there is no opportunity even to control cooling

I tried my 7800xt mining with windows latest graphic driver for this card and downvolted it by AMD software adrenaline and it works, also cooling control works fine. But I hate windows , I like linux platforms for mining. If there exists a working windows graphic driver could it be possible somehow to speed up hiveos updating at last for full 7000 support. I’m waiting for this impatiently.

I’ve been looking forward to this with my 7900xt since April last year. If I knew that it would be so bad with support, I would never have bought it… Support driver 22.40 for AMD 7900xt - #8 by keaton_hiveon

:cd: Hive OS Linux Client Beta Image

  • Based on Ubuntu 20.04 distribution
  • Linux kernel v6.1.65
  • Nvidia v535.154.05
  • AMD kernel module: 6.3.2401.0, ROCm OCL: v5.4.6
  • Intel Arc Kernel Module: 6.3.13_bp, OCL: v23.30.26918.9
  • Integrated some USB Wi-Fi not included in kernel 6.1.
  • Integrated the latest Hive OS Linux Client v0.6-225

Release Notes:

  • For AMD RX 7700 XT / RX 7800 XT you need to manually upgrade to ROCm v5.5+ e.g. amd-ocl-install 5.6.
    ROCm v5.4 is integrated into the image, but Radeon VII on TeamRedMiner does not work on it, although it works on SRBMiner and lolMiner for example.

The fans on the cards do not respond at all to either the auto fan or the minimum speed, tell me what can be done?

Keep in mind this is a community forum and its a weekend, if you’d like to contact support you can email [email protected] or use the chat on

Per your question about fan speed, did you manually update drivers as halo mentioned above?

I don’t want to offend anyone, sorry for being rude. There are no days off in mining, OS receives money from miners every day, even on weekends) well then make a calculation so that money is debited from the account only on weekdays. and on weekends when the support is off, cancel the debits from your account. It’s convenient for me to write here on the forum, because the links you gave in my country are blocked by hive os and I can’t write there. Now the cards are 7800xt sapphire/asrock. Neither the autofan, nor the manual setting, and also the miner setting, does not regulate the fan speed, I tried different settings. And later I found out that the BIOS itself on the card regulates the fan settings, and the fans start only if there is a load on the gpu. I tormented the rig all night, different beta versions of OS + 5.6.1 result was zero. The cards are heating up and the temperatures go over 80+ degrees. As a result, I stayed on Windows and saved $33 a month) to all success and high rates.

You want latest beta + ROCm 5.6 or higher, i verified fan speed control works on a 7900xtx with this combo.

Can you post some screenshots of your workers overview screen? How many 7800xt are you running?

1 Like

Odd, are the fans not working at all? Or just showing 0% incorrectly? I can pick up a 7800xt to test with sometime in the near future.

Haven’t seen anyone buying 7000 series at any kind of scale for mining as they seem like a less than the best choice as far as price/hashrates go.

Here you can see my fan control works as intended on my 7900xtx.

1 Like

With these settings, OC for AMD 7000 series will not work.
At the same time Hive web interface is not ready for AMD 7000 series yet and needs some tricks.
Overclocking for AMD 7000 series GPU has a different scenario than previous GPU and fan control too.

Fan control
There is two options but both are controlled by BIOS, not Hive:

  • static (fans spinned at fixed %)
  • target core temp (fans spinned to keep a little bit lower or equal to some target temp in this case for GPU core)

For static fan control set non-zero value in OC form
For target core temp, set 0 value to OC form and enable autofan, global target core temp settings will be used.

Core clock
You can change for your needs
Core voltage
Not applicable - there is an option Core voltage offset, but this option is currently not present
Memory overclocking
You can disable memory for core-based algos such as blake3 by setting 1 to memory.
Change to other values also should work.
SOC clock and voltage, VDDCI, and other
not applicable

Some screeshots from me :melting_face:


1 Like

Thanks everyone for the detailed discussion. I agree, these 7700/7800 are completely different, we are waiting for the OS update.

I have tried to set my memory to 1 and to 96 but it won’t stick? I installed ROCm 5.7. How did you get yours to stay at mem state 0 and 96mhz?