Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Adding Drivers to HiveOS Image before 1st BootUp

I’m rather new, so please be patient.

Is there a method to add USB-WiFi drivers to a clean vanilla HiveOS Beta image already placed on a SSD drive? OR is the only way to add drivers to a clean vanilla HiveOS Beta image is AFTER a booting up?

Enter the chicken or the egg argument. Suppose that I need to add drivers to HiveOS in order to get an unsupported USB-WiFI operational. I’d have to use a supported USB-WiFi device first in order to establish an internet connection in order to download new drivers for the new unsupported USB-WiFi device. (Solution: Just use what works the first time and keep it at that! Yes, I know.)

FYI: This USB-WiFi device works (0dba:8179) on a vanilla install of HiveOS Beta: TP-Link USB WiFi Adapter for PC (TL-WN725N), N150 and the cost is $8.00 on Amazon USA. Now this device does not work with a vanilla install of HiveOS Beta (2357:011e): TP-Link Nano AC600 USB Wifi Adapter (Archer T2U Nano)- 2.4G/5G Dual Band Wireless Network Adapter for PC Desktop and costs about $15.00 on Amazon USA.

The point of this post is to somehow add support for the AC600 device from the beginning after burning the HiveOS Beta image to the SSD.

Now, you can search for something like “TP-Link AC600” and “Linux” and find install guides on this forum and on Google detailing how to update drivers to include the AC600 model … but notice that you’d have to have an established internet-network connection to the rig in the first place in order to update the drivers.

  1. So, what I did was begin with the USB-WiFi that “just works” out of the box with HiveOS Beta (0bda:8179).
  2. I plugged in the AC600 to the rig at the same time (2357:011e).
  3. Then I updated the drivers using a guide found on Google. Keyword: “make,” “2357:011e,” and “linux”.
  4. After the new driver was downloaded, I removed the 0dba:8179 device and left only the 2357:011e USB-WiFi device in.
  5. I powered down the rig for a few seconds.
  6. Powered on the rig, and it connected to WiFi just fine.

At the present time, I have 1 rig with 8 x 5700 XT Bios modded cards, generating 450.1MH/s for ETH, consuming less than 1250W total (as measured from the wall). It appears that the amount of data transfer involved with hashing is very, very, very small.

To install the AC600 USB WiFi adapter:

sudo apt install git dkms
git clone
cd rtl8814au
sudo make dkms_install


:beers: :beers: :beers:

1 Like

Very helpful! I faced a similar issue when trying to setup this usb wifi dongle USB WiFi Adapter 1200Mbps Techkey Wireless Network Adapter USB 3.0 WiFi 802.11 ac with Dual Band 2.42GHz/300Mbps/5.8GHz/866Mbps 5dBi High Gain Antenna for Desktop Laptop Windows XP/7-10/ Mac OS: Electronics on a Biostar TB250-BTC PRO motherboard. It worked right out of the box with the ASRock H110 Pro BTC, but required explicit driver installation for the TB250.

You still need an internet connection to download the drivers initially, but here are the drivers that worked for me: cilynx/rtl88x2bu: rtl88x2bu driver updated for current kernels. (

would that work with this ?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.