Increase your income with Hive. Invite your friends and earn real cryptocurrency!

6th graphics card not working in B250 Mining Expert motherboard

Any help will be appreciated! If I add a 6th card it doesn’t work. The card shows up in HiveOS, but it doesn’t show the memory type and it can’t mine. The 16x slot is being used (by a different card) and the first 4 of the 1x slots are being used by other cards, so this card is in the 5th 1x slot. All cards (including the 16x) are on powered risers and I am only using one power supply. My cards are all AMD 5700 XTs.

There is nothing wrong with the card, I was able to plug it into an earlier slot on the board with a known to be good riser, and it worked fine in that slot. But that doesn’t solve my problem because then I still have one card not in use.

I have not yet 100% ruled out that this could be a riser issue (either the USB cable, the 1x card, or the 16x board), but it seems unlikely since I have tried 3 different risers from 2 different companies. This is something I will work to rule out if I run out of other options, my rig is difficult to work with for stuff like this, so I’m hoping I will find a different solution since I don’t think it is a riser issue.

I have not yet ruled out a power cable issue. I don’t think it is since these are quality cables, but I will do some work to rule this out at some point if I run out of other options to figure out what is going on.

This is the first time I have tried adding an additional card to this rig since I switched over to HiveOS from msOS. Not sure if that provides any potential clues. I haven’t changed any of my motherboard settings since I made the switch to Hive.

I tried plugging it into the 6th 1x slot, leaving the 5th 1x slot empty with the same results.

I have now ruled out any bad risers, cables, or graphics cards. So I do have an an extra, known to be good riser, graphics card card and cables all being used together with this 6th graphics card and it just doesn’t want to work. So it seems there is just something about adding a 6th card that this motherboard does not like.

I guess my next step is to rule out that there is something wrong with the 5th 1x slot by trying to use it with one of the 5 working cards. Once I can rule that out, I can try researching if there are some more recommended motherboard settings than the ones I am using for the combination of the B250 Mining Expert and HiveOS. I can also try switching back to msOS, at least temporarily see if that makes the problem go away.

You are not alone, I’ve been fighting this problem, well very similar. I suspect it’s the board as well, after moving cards, upgrading, downgrading cables, yada yada. I thought was a bad card crudding the whole board. even put the card on a shelf for a while.
It’s a 12 gpu rig. I believe it had a problem and got caught in a reboot cycle. I got working by not even using the first “section” or combination there of, just used the last 12 pcie slots. my setup was not drawing a lot of power Do not recommend. Ultimately I’m waiting to replace the board. I also feel that the problem could have been caused by the board “drooping” cause I feel like maybe there’s some lines burnt somewhere or cracked or something. At one point I have it running but always the “6th” gpu would throw a rejected share every few hours.

1 Like

I have now ruled out the possibility that something is wrong with the 5th 1x slot. While only trying to use 5 graphics cards, which has been working fine, I moved one from the 4th 1x slot to the 5th slot. All 5 cards are working great like this.

So here is what I have learned so far:

  • None of the equipment I’m trying to use is faulty, it all works (risers, cables, motherboard slots)
  • I can use 5 graphics cards with no issues
  • No issues arise (so far) from skipping a 1x slot
  • If I add a 6th graphics card, and plug it into one of the A 1x slots, it doesn’t work. It doesn’t matter which slot I use.

The next thing for me to try is to plug the 6th card into one of the B 1x slots.

I tried plugging in a 6th card to the first B 1x slot (all the Bs are 1x). The card works, but then one of the other cards from the A slots stops working! My board only wants to work with 5 cards.

My next test is to move it to the first C slot.

I’m telling you man it’s the board. It can work intermittently depending on slots used.

Do you have a recommendation for a good 16 GPU board to use with HiveOS? I say 16 because this is the most Linux OSs like HiveOS can typically handle.

I get the same result when I plug the 6th card into a C slot. It works, but one of my other cards in the A slots stop working.

The only other thing I can try is moving all the cards over to B or C.

I did move most over to B or C. I’m not saying the board is bad in general, i’m saying it’s faulty. I think that mine got zapped somehow or cracked or maybe a faulty component. It wasn’t always like that.
Do you have a spare?
I thnk i ended up using only back slots in A, back and right slots B, All of C. Make sure you have that triple molex plugged it for sure.

Mind you I was using lower powered cards for this.

If you get more than 14 on this let me know, I believe you can do 15 in windows. Without the p106 cards.

Im planning on using my board to run “left over” GPU’s.

The other thing you can keep doing is keep “moving” slots until you find a selection that “works”.

Finding the right combination that will work is a crazy game of musical cards for me. All the slots are working fine until I try to use 6 cards, then one of the slots randomly doesn’t work. If I move that card to a different slot, it might start working and then a previously working slot stops working.

I am beginning to see a repeating pattern. Whenever I try to use 6 cards, I think it is always the same card that does not work. However that card works fine when I only use 5 cards. It seems to not matter which slots I use, this card specifically will not work when I use 6 cards.

I moved the “troubled” card into the 16x slot. Now it works and one of the other cards does not. So the problem is not related to a particular card.

It was recommended to me to power the 6th card from a second PSU. This helped someone else with the same issue on a different motherboard. He said it was not a logical solution since the one PSU should have been enough power, but for some reason powering his 6-8 cards from a second PSU got them working.

Could be, I have one rig with dual 1000 psu’s and one with a 1300 with a 1000. The 1300 one is the one that gives me issues haha. do you have that 3x molex plugged in?

Extra PSU didn’t help :frowning:
Some other things I will probably try at some point, but don’t expect them to help is updating the AMD drivers and switching to Phoenix Miner. Beyond that I don’t think it is worth trying anything else. I’d rather just be happy with 5 GPUs on this board and move onto other boards in the future. This motherboard has a bad reputation in the mining community, so I will probably avoid it going forward, and also the Mining Master even though it looks really cool.

I’ve been using the asus b250 mining snob (I have two identical ones, but usually only using one at a time.) These things are tanks. I’ve used and abused mine and it keeps going. One of the ports caught fire. I blew it out and it kept going, except with one port less.

5700xt’s are a power hungry card (225watt max). Not saying your PSU is the ‘root’ cause, but its probably affecting stability if your PSU is starved for power. 225 x 6 = 1,350. Say you undervolt it to 125 watts then thats 125x 6 = 750 watts; still pretty close to the limit of a 1000 watt PSU, and you’ll need to factor in the equipment power draw, which will be (AT LEAST) 80 watts.

There really isn’t anything else out there, I thinking MSI has a mining board… but at this point they’ve all been marked up about 250% in price so you should just hunker down and get comfy because running three 2 card mining ‘rigs’ SUCKS. The savings in power would allow you to run an extra GPU, at least. Running 2 (6x ) rigs sounds great, but logistically if they’re in the same building you’re doing it wrong, plus you’re paying for extra equipment that you ‘must maintain.’

If you think 5/6 cards is going to drive you crazy try 12 or 14. You must take into consideration that sometimes your video cards will reset (momentarily) to stock clock/voltage settings and some PSU’s /GPU’s might not like this and crash. Some issues may pop up due to mixing of different types of risers. You should not be loading PSU’s past 65% if you want it to run for weeks on end.

Some of it is hiveOS issues (I haven’t been successful with the later versions of hiveos.) Sometimes its a miner issue; Phoenix miner has ALWAYS had issues especially with the EthPill.

Point is the power delivery on the motherboard is unmatched; you’ll have piece of mind that one typo in the hive mobile-web interface won’t cause your farm to crash and burn (maybe just crash, and boot-cycle).

I went through the same issue with that board. You have to mix NVidia with AMD to get it to work. They have a guide mapping which slots can be used for what manufacurer card. I ended up sending the board back. Now I’m running 13 cards in a H110 Pro BTC stable.

With 5 5700s working, entire rig is only drawing 711 Watts at the wall. I have the cards configured for maximum efficiency (MH/W). It doesn’t seem to be related to the PSU. Even after adding a second PSU, the problem was exactly the same, 1/6 cards is chosen at random to not work.