Increase your income with Hive. Invite your friends and earn real cryptocurrency!

5700XT GIGABYTE _Black Screen after Flash and Restart_Need HELP!

I´ve flashed my RX5700XT GIGABYTE using amdvbflash ( i first saved the original Bios) on Cmd (normal mode) and I have thought everything went fine. After all the steps i had to restart the computer. After I restart it appears a black screen and I can´t even enter in the motherboard bios.

My MB is a Asus B250 and has onboard video. To been able to start windows again I had to disconnect the Power PCI-E cables from the GPU ( the GPU it´s still inserted in the board).

After entering in windows i´ve tried amdvbflash on cmd and also the Amdvdflashs windows file. Both don´t recognize the GPU.

The amdvflash on CMD says “adaptor not found”

The windows amdvbflash says “can´t find discrete ATI video card”,

I´ve been trying to resolve this issue without success. Can you guys help me?

Thanks in advance

did you try to re-connect Power PCI-E cables to the GPU? I cant imagine that you can flash them if they are not connected to the mainboard. If you did and windows didnt find your card…try to run hiveOS and check if Linux finds it.

I think you flashed a wrong bios file…you didnt told us what file you flashed or what you changed…I think that could be the problem…I already flashed some stuff that killed my 5700 too…it´s very easy to kill a 5700 with flashing the wrong stuff :wink:

Thanks for the reply,

“did you try to re-connect Power PCI-E cables to the GPU?” You mean after windows booting? -No I didn´t. Let me try that…

Hive OS doesn´t find the GPU.

I`ve created the rom from this tutorial:

After that I restarted the computer. Every steps went fine, no errors whatsoever, except last one.

After rebooting I´ve reconnected the PCI-E power cables, didn´t work. Windows and HiveOS Can´t find the GPU.

start over flash original rom.

How? System doesn’t identify the GPU. I can’t seen to have acess to it.

Don’t run Phoenix miner, does it show up as GPU in hive? I may have misunderstood.

Hi Rawbones, HiveOS doesn´t seen to recognize the GPU.

Boot up, don’t run miner, does it show up on the webgui as something there?

Basically the ROM is signed, you have to flash an older version to get to flash a modded version.
You can push the original bios via amdvbflash. And if it doesn’t work with the origianl bios, get one from techpower up to get you started at the beginning.
Hard lessons learning to flash, hopefully not expensive

I have the orginal Bios. Before I flash the card I`ve saved the original one. “Webgui” what´s that?

There is an option from here to flash the bios.
Hopefully I was helpful to get you going again.
Take care.

I am having the same problem.

Did you solve the problem?

I sent the product to the service.
They will probably write and send bios.

As for the product, I don’t know what to do. I’m afraid to try to write bios again.


Yes I did. I was abble to flash back the original Rom and restore the GPU. I just had do put in another motherboard. The problem was the B250 mining expert from Asus, it didn’t recognize the GPU. After i tried it in another MB i was abble to flash it under DOS using Amdvbflash tool.

Any path to mod a gigabyte 5700xt card, without getting black screen ? Once I tried with it and failed then reloaded original bios after buying a new saphire 5700xt GPU to boot into windows as my processor not have inbuilt GPU. Can anyone help to mod the gigabyte bios, as I’m only getting 52MH/s with gigabyte card , while my saphire is giving 53MH/s. I heard gigabyte have some signed bios, any way to bypass their signed verification ?

You have to downgrade the BIOS with an older one. Only after that you can flash it normally.

Where to find an older bios for Radeon RX 5700 XT 8176 MB - Gigabyte ?

You don’t need an older one, you just need an unlocked one. I’ll get you a link!

Follow this link to a unlocked and bios modded with memory straps. For further bios modding please follow the step by step instructions on page: 15 (you can skip step 1 since you’ll be using the provided bios and you can skip step 19 with the memory timings part since apple straps are already applied to the linked bios.

1 Like

Great, thanks for help. Gained 4+MH/s rightaway. I tried to use same settings and made modifications for my saphire nitro+ 5700xt bios also, but that card is crashing soon after mining is starting. (even some error messages pops soon after login to hiveos also, amdgpu failed bla bla). Can you help with saphire nitro+ also it is only working in stock and only having 52- 53 Mh/s. )