Increase your income with Hive. Invite your friends and earn real cryptocurrency!

3070 PCI-E Issues?

Hey All,

I have been going over and over this but can’t find a better fix.

I have a small rig at the moment, 2 x 3080s and 2 x 3070s, the 3070s are Zotac RTX 3070 Twin Edge OC and have been working quite well so far, apart from the issue below.

It seems that the only way I can get one of the 3070s to work is to plug it directly into the 16x slot of my ASROCK 970 Extreme 3, the other three cards work just fine from a 4 x 1 PCI-E card with x16/x1 risers. I’ve even confirmed that the identical (vBIOS versions too) Zotac 3070 card works just fine and displays output when plugged into the riser and into the PCI-E card, as soon as I plug the offending 3070 into the card (or even using one of the many PCI-E riser single ports) I have no display and Hive can’t find any cards or sometimes just ignores the ‘bad’ 3070.

I ended up buying a new motherboard as the asrock was just an old spare, Gigabyte H410M H V2 - I’ve enabled the usual 4G Decoding, disabled IOAPIC, Gen 1,2,3 etc… but it’s still the same experience! the only thing that’s different is that the problem child 3070 won’t even work in the 16x slot!

Really stuck here, I’ve tried multiple risers and most troubleshooting steps you could think of, hoping that someone may know the answer that doesn’t involve me submitting an RMA for something that :

a) works in a ‘normal’ fashion in a 16x slot

b) will probably take 6 months to replace due to the shortage

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.