More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Set up HiveOS remote shell session automatically

Thanks for the suggestion. I just added the user guest to etc/sudousers, but when I do ssh [email protected] and try running a sudo command, I get an error.

[email protected]:~$ cat /etc/sudousers
guest
[email protected]:~$ sudo -i
[sudo] password for guest:
guest is not in the sudoers file.  This incident will be reported.

Did you remember to restart the server/deamon? And guest might be a blocked username. So you can also try changing username…

Any idea how to use WinSCP? I can connect via SSH from PuTTY, windows shell, or the hive web site, but not WinSCP for some reason. The winSCP app is really useful as a GUI. It is refusing to start shell/command. Have tried with SCP, SFTP and used the default and bash (the latter is recommended). But no luck

I use SFTP and I can access it

I tried but no luck. What are your exact settings when you use SFTP? Default doesn’t work, tried all versions. Same as when I use SCP instead of SFTP it authenticates, and says system starting, the hangs. Eventually says maybe no SFTP server running. I am using this against an L3++ with latest HIVEOS.
Thanks!

I don’t even remember anymore and don’t access it that way anymore. Maybe in the future I’ll try to figure it out again, right now I haven’t looked back into it yet. The SFTP isn’t working anymore for me