Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 5700 XT not mining in HiveOS

Its all about driver and oc settings for this card…
With stock bios 5700 plays from 1300-1350 and mem 850-900… is has power consumption ~150-170 watt… with your riser if you have…
The polaris with stock bios card plays at Core 1150-1200 with VDD at 850-900 and mem 1950-2150
So check your hive os image… i have the same and use it with 5700 and 580 cards…(no problem at all)
Kernel Version 5.4.0-hiveos #108
Client version hiveos

Hi, thanks for the reply.

I’m running Kernel version 5.4.0-hiveos #140
I’ve tried to mod & flash the GPU bios, following the instructions on Mining Chamber YT, but keep getting a write error. Confident i’ve done everything correctly, so i guess it’s an issue with the card.
Hiveos is not running in Windows, it’s a stand alone bootable system.

what brand 5700xt u have?

What mem (samsung? or micron?)


U have the stock bios for this card? Maybe has wrong bios …

I presume it’s the stock bios. Is there anywhere i can find out what the stock rom should be ?

I have recently tried to mod & reflash the bios. I followed instructions by The Mining Chamber exactly & i get a 0FL01 error. Also get this error when i try to flash with ‘original’ stock rom.

this is the latest bios for your GPU…

Do you flash it through windows?
If you have Hiveos is very simple to do it from there…
0FL01 error (if u mod it with with amdvbflash wrong version ) What version of this sofware u have mod it?

Thanks for the link but that’s for the Gaming X, which i don’t think i have.
I flash in windows as my Hiveos is on a standalone system (no windows). I am using Amdvbflash 3.04+ with RBE & MPT that i got from Igorslabs.

I think u can use Flash Tool 2.93+ Win for windows …
Download your bios from VGA Bios Collection | TechPowerUp

Downgrade to 0.6-203. I have two 5700xt rigs, and they constantly reboot on higher hiveos versions.

I also followed the guide here to flash modified 5700 (non-xt) bios on all of my GPUs.

I solved the 5700 problem by turning off autofan.
I put the cooler at 40% and it was stable, I’ll do more tests with higher speeds

Was your 5700 mining anything or was the hashrate just lower than expected ?

Wrong person


Ok. Mine is barely doing anything, almost to the point of being idle.

I am running into the same problem. I am not sure if you are still mining, especially given the current climate. I also posted on this subject. Were you ever able to find a solution?

Thank you!

No I never did find a solution to this & have stopped mining since. It’s odd because my RX590 would mine but the Rx 5700 XT wouldn’t. What’s also weird is that the 5700 will mine within Norton’s mining program but not on HIve. I can only guess that it is a driver issue.


This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.