Increase your income with Hive. Invite your friends and earn real cryptocurrency!

ASUS PRIME Z490-A - Please fix Hive OS Devs

I have a brand new ASUS PRIME Z490-A MB with a Intel G6400.

Running Windows 10 Home x64 (20H2) – latest build

The computer is 100% fine, however I wanted to be more profitable and give Hive OS a shot. I flashed up an SSD using balenaEtcher as well as Rufus and tried both the stable and the beta versions of Hive OS with zero success. Like some forums said, I even tried switching all my GEN1 to GEN2 via BIOS.

The built-in INTEL NIC on the MB does not connect. Also depending on which way I flashed it, I would also have some display issues (blank black screen). I even tried an Anker USB 3.0 to Ethernet LAN, and that didn’t even connect my rig :frowning:

Even though I’m new here and to Hive OS, I followed and referenced several guides all which lead to a bad result. After flashing my SSD I would of course copy over my rig.cfg file and then attempt to boot from it. Not once did my actual rig ever appear via the Hive OS GUI.

Any information or ETA on a fix for this would be greatly appreciated. I want to get off Windows but at this rate it doesn’t look possible.

Thank you,

check this

also this


Man, I’m not a linux guy… Does anyone know about to make the NIC on a Z490-A work with manually installing the drivers?

The shitty thing is, I have a 6+ year old crappy MB/CPU combo and I just tried it and it worked flawlessly… :’(

1 Like

I have followed the guide above with success to get network working on hive on this MB, I have another issue purely bios related that it will not boot with more than 10 cards or so (I have it working on 14 cards, but it required manual intervention on cold boot because it does not go past bios screen)

1 Like

How did you get more 8 cards on this MB?

Do you mind sharing exactly what you did?

Using x4 PCI riser: New 4 Ports PCIe Riser Adapter Board PCI E 1x to 4 USB 3.0 PCI E Rabbet GPU Riser Extender Ethereum ETH/Monero XMR/Zcash ZEC 16X|Add On Cards| - AliExpress

Thanks for sharing. I ordered 2 and will give them a shot!

I had the same problem. Downgrading BIOS, changing PCI-e generation, nothing helped. At the end I turned off “Intel Rapid Storage Technology” from Main screen of BIOS and I could load Hive OS.

To get the NIC to work on my ASUS Tuf Gaming X570-Pro board I have to unplug the network cable when starting to boot into HiveOS, then plug it back in 15-20 seconds later (the timing is critical - too soon and it will not work, too late and the boot process will be passed setting up networking). I’m not kidding, I unplug my network cable, start the PC and hit Del to go into my BIOS, pick my boot drive, hit enter on the blue menu, count 17 Mississippi’s and then plug in the network cable.

Can I ask you help I have the same board and I am trying to get 5 cards to work on it can you help me and tell me what you did in the BIOS to get the cards working

How many GPUS did you get working on this board?

11 GPU work great without any issues (the lan is fine on latest stable version)
12 to 14 work , but the rig will not bot without human intervention since it boot always to bios and then need a manuel intervention to start HivoS.

I wonder if it is the same I have the ROG STRIX z490 A

and how do you manual start it
I have the same issues with mine if I hook all the GPU it wont boot

Do you have DISCORD to chat with me

Hello, how can you manage to do it with 14 GPUs.

I have 11 GPUs with 1 pci extender and works perfectly all the time, no issues in days and days. When i put another pci extender and connect the 12 GPU, it start good but in maybe 1 hour (or something) it crash and come offline. I dont know how to do, i got some different extenders but it seems to be the same…

Need help please.

Any help please?