Increase your income with Hive. Invite your friends and earn real cryptocurrency!

ASUS Prime Z390-P - Added 5th GPU but it's not recognized - Please help!

I’ve had 4 cards running great mining RVN for the last month or so at about 108 MH. Today I tried adding a 5th GPU to the mix (MSI Geforce 3060ti RTX). It powers up and the GPU lights up and risers show power but the fans never kick on and HiveOS doesn’t see the card at all.

I’ve looked through multiple forum posts, videos, and tutorials and I have done the following:

  • Tested multiple risers including known good risers from currently working GPUs
  • BIOS Flashed to latest
  • BIOS set to recommended settings per forum posts
  • Nvidia Drivers all updated
  • Changed PCIe → Gen1

Yet the GPU still doesn’t show up anywhere. What am I missing?

Tested PCIe on all 4 options:

  • Auto
  • Gen1
  • Gen2
  • Gen3

None of which made any difference, the new GPU is still not recognized at all.

I have verified the card are risers are good. I’ve successfully booted HiveOS with 4 cards (new one included) but anytime I add a 5th card, regardless of which card it is, I am unable to get the system to properly boot, even to the BIOS from what I can tell.

Based on some more info from the thread below I’ve continued tweaking, but to no avail.

  • Disabled all SATA ports (except #2 since that’s HiveOS SSD)
  • Can’t disable onboard LAN (for obvious reasons)
  • Disabled audio
  • Disabled memory remap
  • Enabled 4g decoding
  • And tried using PCIe gen1, gen2, and gen3

did you disabled the usb ports?

Haven’t seen anything about disabling the USB ports, not sure why they would matter. And besides, you need USB ports in order to edit the BIOS.

I have a 270, but on mine the usb 3 (front) shares the pci lanes with one of the pcie slots

Have no idea where in the bios the setting is lol, however, my slot didn’t work until I changed it from usb to pcie

Good info, thank you. But I don’t think that’s the problem here because it doesn’t matter which slot I use. Any combination of 4 GPUs works fine, but as soon as I add the 5th, no matter which one it is, it fails.

What CPU are you running?


6 × Intel® Core™ i5-9400F CPU @ 2.90GHz AES

Have you tried following this video:

Good video, all the settings in one place. Unfortunately, I’ve already made all the same changes he has shown, but I had to find them in multiple places.

So apparently all I was missing was to turn off CSM! 5 GPUs reporting, 5 GPUs mining, it’s a good day for this rig finally!


Same issue, where is the CSM setting? There seems to be a few. Thanks!

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.