Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asus B250 Mining Expert - watchdog: BUG: soft lockup - CPU#0 stuck

Has anyone using the Asus B250 Mining Expert board with an Intel i5 or Celeron CPU (I’ve tried both) gotten this error?

I get it about half the time on boot and every time on reboot. For reboots I have to do a hard power off or it just sits there forever.

I’m running HiveOS v0.5-53 and am about to try downgrading to a version that I’m running on my other rigs with the same CPU with no problems. They are running the MSI H270-A Pro motherboard, though.

I highly suspect it’s not HiveOS, but the B250 board, but I just want to do my due diligence to narrow the problem down.

1 Like

The best thing I can find on this is here.

Did you find the culprit? I’m have the same issue.

Just an update on this. I have had zero luck figuring out what the problem is. I have tried 3 different B250 boards in 3 different systems and they all do it at some point or another.

Sometimes they boot up clean and quick, other times they don’t and take like 10 reboots to come up clean without any hangs.

I would love to know what the problem is here. It can’t possibly be a power issue I’m using 2 x 1500w platinum rated Silverstone and Corsair PSUs and only have 12 x RX570 cards.

Want to know if someone have solution for this? I got everytime this error, tried with different CPU Settings, with an SSD etc. nothing helped.

The only thing I found that helps is flipping the PSU A off on the rig for about 10 seconds then flipping it back on. Then it will usually come up clean. If it crashes and reboots it’ll do it again.

Are you using AMD cards by chance? I have 4 rigs using AMD cards that have this problem and one that is using Nvidia that doesn’t have the problem. I’m starting to think it has something to do with the AMD cards/drivers/B250/Linux.


For some reason PCIE setting of my motherboard was Gen1 instead of Gen2. After I switched it to Gen2, the problem was solved.

Mine are set to Gen 2 and still have the problem if it gets rebooted. If it’s a hard power on it’s usually fine. It doesn’t do it with Nvidia cards or Vegas, it just seems to be with AMD RX cards.

Frustrating to be sure.

Hi @Kuzuri!
What linux image are you using? I was unable to start current stable image with B250 ME motherboard so have to stuck with 5.0.21-hiveos (latest Beta). But it produce own issues. When soft reboot is initiated it can not connect to network until hard reboot so hive watchdog become pretty useless.